OpenRoads Designer CONNECT Edition SDK Help

Intersect(DPoint3d, DVector3d, Double) Method

Gets collection of intersections with an infinite vector starting at origin.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearIntersectionCollection Intersect( DPoint3d origin, DVector3d vect,double ptToPtTolerance)

Parameters

SettingDescription
  DPoint3d Origin of the vector.
  DVector3d Vector.
   Point to point tolerance.

Return Value

LinearIntersectionCollection Intersections with the vector.

See Also